Font-Problem mit Google Schrift auf dem eigenen Server!

Allgemeine Fragen
inno
Mitglied (Level 10)
Mitglied (Level 10)
Beiträge: 155
Registriert: Do 17. Dez 2020, 11:59

Font-Problem mit Google Schrift auf dem eigenen Server!

Ungelesener Beitrag von inno »

Hallo,
ich lade einen Textbereich mit einem Include auf die Homepage.

Code: Alles auswählen

<div class="mbr-regular">

<center>
    <?php
$Quelle = ("./content/news.txt");
include($Quelle)
?>
    </center></div>
Die Google-Schrift habe ich auch lokal auf dem Server gespeichert.

Alles andere wird richtig angezeigt nur für den geladenen Textbereich, wird die Times verwendet.
Hier noch das CSS.

Code: Alles auswählen

.my-image {
  width: 1000 px;
}
.mbr-regular {
      font-size: 4 rem;
    font-family: regular;
    color: #767676 ;
    line-height: 24px;
}
Was kann ich machen?

Danke für die Hilfe!
Benutzeravatar
Tommy Herrmann
Site Admin
Site Admin
Beiträge: 2947
Registriert: So 6. Dez 2020, 07:37
Wohnort: Berlin
Kontaktdaten:

Re: Font-Problem mit Google Schrift auf dem eigenen Server!

Ungelesener Beitrag von Tommy Herrmann »

Moin,

wieso inkludierst Du denn den Text? Was könnte das für einen Vorteil bringen? Es fehlt auch ein Semikolon am Ende der "include" Zeile.

Haben die inkludierten Texte denn auch die richtigen CSS-Klassen?

Zeige mal den Inhalt einer solchen von Dir inkludierten Textdatei hier (oder auch einen Link).

Insgesamt hatte ich hier kürzlich eine Anleitung zur Verwendung von lokalen Fonts geschrieben:

https://www.mobirise-tutorials.com/Local-Fonts/
inno
Mitglied (Level 10)
Mitglied (Level 10)
Beiträge: 155
Registriert: Do 17. Dez 2020, 11:59

Re: Font-Problem mit Google Schrift auf dem eigenen Server!

Ungelesener Beitrag von inno »

Weil der Kunde den Text dort selber pflegt!
Schaue ich mir an!

Danke! :tu:
inno
Mitglied (Level 10)
Mitglied (Level 10)
Beiträge: 155
Registriert: Do 17. Dez 2020, 11:59

Re: Font-Problem mit Google Schrift auf dem eigenen Server!

Ungelesener Beitrag von inno »

Perfekt beschrieben! Hat funktioniert! Danke!
Benutzeravatar
Tommy Herrmann
Site Admin
Site Admin
Beiträge: 2947
Registriert: So 6. Dez 2020, 07:37
Wohnort: Berlin
Kontaktdaten:

Re: Font-Problem mit Google Schrift auf dem eigenen Server!

Ungelesener Beitrag von Tommy Herrmann »

... das ging ja schnell :angst: :tu:
Antworten

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot] und 1 Gast